Feeds:
Inlägg
Kommentarer

Posts Tagged ‘kompatibilitet’

Nu har bankid krånglat till det ännu mer…

Inte nog med att de inte stödjer 64-bitars linux OS. De känner också av vilket OS du har installerat genom att läsa av ”byggets identifierare” i firefox…

Det ställer ju till problem. Nu kan man över huvud taget inte ladda ned bankid säkerhetsprogram för att krångla med det som tidigare.

Efter att ha slagit mig i pannan några gånger fann jag dock en bra tråd här. Där förklaras kortfattat vad som måste göras för att ställa om ”byggets identifierare” så att bankid tror att du kör med ett 32-bits OS. (se nedan om du inte orkar följa länken)

Sedan måste man ju också lura säkerhetsprogramet att tro detsamma. Det fann jag dock fungerade rätt bra på ubuntu 11.10. Betydligt smidigare än vad jag varit med om tidigare. Det berodde nog mest på de här instruktionerna. Absolut nödvändigt för att detta ska fungera är att ia32libs och nspluginwrapper är korrekt installerade och fungerar som de ska.

Att ställa in firefox (10) så att bankid inte bråkar

  1. Skriv about: i adressfältet i webbläsaren
  2. Kopiera det som står efter ”Byggets identifierare” (i min står det ”Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:10.0) Gecko/20100101 Firefox/10.0″)
  3. Skriv about:config i adressfältet i webläsaren (lova att du är försiktig :))
  4. Högerklicka och skapa ny sträng
  5. Kalla strängen ”general.useragent.override” och klistra in det som du kopierat i steg 2 som  värde. OBS! Ändra så att det står ”i686” i denna – inte ”x86_64” eller något annat som antyder ett 64-bitars OS (markerat med rött ovan).
  6. Starta om firefox och gå till bankid så kan du förhoppningsvis ladda ned senaste säkerhetsprogrammet och följa instruktionerna i länkarna ovan för att installera. Glöm inte ia32libs och nspluginwrapper. De är VIKTIGA!

/Tach och hej…..

Annonser

Read Full Post »